Напишите программу, которая заполняет массив первыми N натуральными числами в обратном порядке (начиная с последнего) и выводит его.
Входные данные
Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести содержимое массива: N последовательных натуральных чисел от N до 1 в обратном порядке.
пример
входные данные
5
выходные данные
5 4 3 2 1
Ответы на вопрос
Ответил fedrfedr
1
Ответ:
program ArrayOfNum;
var
n, i: Integer;
a: Array of Integer;
begin
Write ('Введите N: ');
ReadLn (n);
SetLength(a, n);
for i := Low (a) to High (a) do
a [i] := n - i;
for i := Low (a) to High (a) do
Write (a [i], ' ');
ReadLn;
end.
Новые вопросы