Напишите программу, которая заполняет массив из N = 8 элементов случайными числами в диапазоне [0,10], выводит его на экран, а затем выводит на экран квадраты всех элементов массива.
С++
Использовать библиотеки #include
#include
Ответы на вопрос
Ответил aynurppp
0
Ответ:
Код можно сократить вплоть до одного for, объединив все в одно. На будущее: #include - это не библиотека, это директива
Объяснение:
#include <iostream>
#include <random>
#include <time.h>
using namespace std;
int main() {
int mas[8];
srand(time(NULL));
for (int i = 0; i <= 7; i++) mas[i] = rand() % 11;
for (int i = 0; i <= 7; i++) mas[i] *= mas[i];
for (int i = 0; i <= 7; i++) cout << mas[i] << " ";
}
Новые вопросы
Геометрия,
1 год назад
Английский язык,
1 год назад
Английский язык,
1 год назад
Математика,
7 лет назад
Алгебра,
7 лет назад