Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке {-2,2} и находит произведение ненулевых элементов.
Ответы на вопрос
Ответил elenaklon
0
const n=10;
var a: array [1..n] of integer;
i,p: integer;
begin
for i:=1 to n do
a[i]:=random(-2,2);
writeln (a);
p:=1;
for i:=1 to n do
if a[i]<>0 then p:=p*a[i];
writeln (p)
end.
var a: array [1..n] of integer;
i,p: integer;
begin
for i:=1 to n do
a[i]:=random(-2,2);
writeln (a);
p:=1;
for i:=1 to n do
if a[i]<>0 then p:=p*a[i];
writeln (p)
end.
Ответил Umper
0
спасибо)
Ответил AnonimusPro
0
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var a:=ArrRandom(10,-2,2).Println.Where(x->x<>0);
write('произведение ненулевых элементов: ',a.Aggregate(Real(1),(a,b)->a*b));
end.
//Версия 3.3.5, сборка 1650
begin
var a:=ArrRandom(10,-2,2).Println.Where(x->x<>0);
write('произведение ненулевых элементов: ',a.Aggregate(Real(1),(a,b)->a*b));
end.
Ответил Аноним
0
Real(1) - это что за извращение и зачем? 10 чисел, не превышающих 2 по модулю, дадут произведение не больше 1024. К чему переводить в вещественное? Но даже если переводить, наверно проще написать 1.0 вместо Real(1)
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад