Информатика, вопрос задал ipad17112000 , 2 года назад

Напишите программу которая заменяет буквы введенной строки на следующие через n. Считать что алфавит закольцован, т.е. если следующей буквы нет то начать выводить сначала.(питон)

Приложения:

Ответы на вопрос

Ответил wherethefux
0

alphabet = 'abcdefghijklmnopqrstuvwxyz'

string = input("Введите строку: ")

n = int(input("Введите n: "))

result = ""

for i in string:

   if i in alphabet:

       result += alphabet[(alphabet.index(i) + n) % 26]

   else:

       result += i

print(result)

Новые вопросы