Информатика, вопрос задал flappykiw1i , 2 года назад

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N включительно ( 2 ≤ N ≤ 100000 ).


renat8059: Тебе на какой платформе?
renat8059: смогу на C#
flappykiw1i: а на паскале?
flappykiw1i: если сделаешь на паскале, то конечно буду очень благодарен.
flappykiw1i: но моя ошибка, да.
renat8059: Сорри бро
renat8059: не изучаю паскаль (
flappykiw1i: Ок, все равно спасибо.

Ответы на вопрос

Ответил restIess
1

var

N,i,k,x:integer;

begin

readln(N);

for i:=2 to N do

begin

 x:=0;  

for k:=2 to trunc(sqrt(i)) do

   if i mod k=0 then  

   x:=1;

if x=0 then  

write(i,' ');

end;

end.

Новые вопросы