Информатика, вопрос задал gdusaeva , 7 лет назад

Напишите программу, которая выводит все делители натурального числа, введенного пользователем с клавиатуры
НА ПИТОНЕ

Ответы на вопрос

Ответил vlajong
0

x=int(input())  #просим ввести число от пользователя

for i in range(1,x):#цикл который идет с 1 тк как делить на ноль нельзя и до числа не вкл его

 if x%i==0:#проверка на делимость

   print(i)#выводит результат

Новые вопросы