Информатика, вопрос задал snejokruiz , 8 лет назад

Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

Входные данные
Входная строка содержит неотрицательное число N .

Выходные данные
Программа должна вывести в столбик все цифры введённого числа, начиная с первой.

Примеры
входные данные
1234
выходные данные
1
2
3
4
На паскале.

Ответы на вопрос

Ответил Аноним
0
Без рекурсии:

Procedure ABC(N:integer);
Var
C:integer;
Begin
C:=0;
While N>0 do
   Begin
   C:=C*10+N mod 10;
   N:=N div 10
   End;
While C>0 do
   Begin
   WriteLn(C mod 10);
   C:=C div 10
   End
End;

Var
N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.


С рекурсией:

Procedure ABC(N:integer);
Begin
if N>0 then
   Begin
   ABC(N div 10);
   WriteLn(N mod 10);
   End
End;
Var N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.

Ответил snejokruiz
0
Спасибо большое.
Новые вопросы