Информатика, вопрос задал arinaaznaureni , 7 лет назад

Напишите программу, которая выводит на консоль простые числа в промежутке от [1, 100].

На Яве.

Ответы на вопрос

Ответил FakeDeveloper
1

У меня в папках где-то этот код запропастился.

Везло, везло, наконец-то нашла задачу для решения которого требуется использоватать Java!

public class primeNumber {

   public static void main(String args[]) {

     

//Обьявление числа, с которого начнётся подчёт простых чисел

     int diapazon = 2;

     

//Число 2 движется к 100, через  каждый полный круг увеличивается на единицу  

     for (; diapazon<=100; diapazon++) {

//Обьявление переменной типа логического, проверяющее "простоту" числа

         boolean isPrime = true;

//Под-число "i", обязательно меньшее переменной diapazon, делится на diapazon

         for(int i = 2; i<diapazon; i++) {

//Если под-число делится хоть на какую-то цифру кроме себя, то "isPrime" — равно false, и цикл продолжается до тех пор, пока не найдёт простое число

             if(diapazon%i == 0) {

                 isPrime = false;

                 break;

             }

         }

//В противном случае — isPrime равно "true"

     if(isPrime) {

         System.out.println(diapazon);

     }

   }

}

}

Ответил marineaznauryan
2

for(int i = 2; i <= 100; i ++){

           boolean isPrime = true;

           for(int j = 2; j < i; j++){

               if(i % j == 0){

                   isPrime = false;

                   break;

               }

           }

           if(isPrime){

               System.out.println(i);

           }

       }

Новые вопросы
Алгебра, 7 лет назад