Напишите программу, которая выводит на экран последний член последовательности 1, -3, -7, -11, -15... меньший заданного числа и его сумму с предыдущими членами последовательности
Ответы на вопрос
Ответил hhh54
0
Program hhh54;
var n,x,s:longint;
begin
s:=0;
read (n);
x:=1;
while x > n do
begin
s:=s+x;
x:=x-4;
end;
s:=s+x;
write (x,' ',s);
end.
var n,x,s:longint;
begin
s:=0;
read (n);
x:=1;
while x > n do
begin
s:=s+x;
x:=x-4;
end;
s:=s+x;
write (x,' ',s);
end.
Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Химия,
9 лет назад