Информатика, вопрос задал Herobrin555555 , 9 лет назад

Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n.

Если можно побыстрее, а то на завтра нужно.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln('s=',Range(ReadInteger('n='),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write('n='); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln('s=',s)
end.

Ответил Аноним
0
Я могу Вам написать еще и сугубо школьный вариант. Если надо
Ответил Аноним
0
Будет длинно и противно))
Ответил Herobrin555555
0
Ну если можно то напишите
Ответил Herobrin555555
0
Спасибо за предоставленную мне помощь.
Ответил Аноним
0
Пожалуйста
Новые вопросы