Напишите программу, которая вычисляет минимальное из трёх введённых чисел. Используйте функцию( на C++). Нужно именно исправить данную программу, что не так.
Приложения:

Ответы на вопрос
Ответил shibgena
1
Ответ:
Объяснение:
в 17 строке не "end" а "endl"
azamatkutushev:
Ошибка исправилось, однако после ввода 3 чисел, на экран выводится 0
using namespace std;
int max3(int a1, int a2, int a3)
{
if((a1 > a2)&&(a1 > a3))
{
return a1;//немедленный выход из функции
}
if((a2 > a1)&&(a2 > a3))
{
return a2;
}
return a3;//если дошли до этой строчки, значит а3
}
int main()
{
int a, b,c;
cout<<"vvedi a, b c"<< endl;
cin >>a>>b>> c;
cout << max3(a, b, c);
return 0;
}
using namespace std;
int max3(int a1, int a2, int a3)
{
if((a1 > a2)&&(a1 > a3))
{
return a1;//немедленный выход из функции
}
if((a2 > a1)&&(a2 > a3))
{
return a2;
}
return a3;//если дошли до этой строчки, значит а3
}
int main()
{
int a, b,c;
cout<<"vvedi a, b c"<< endl;
cin >>a>>b>> c;
cout << max3(a, b, c);
return 0;
}
Новые вопросы
Русский язык,
2 года назад
Другие предметы,
2 года назад
Литература,
2 года назад
Экономика,
2 года назад
Математика,
8 лет назад