Напишите программу, которая вычисляет количество цифр числа. Используйте функцию.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
function nDigits(n:int64):integer; // если число
begin
Result:=0;
if n<0 then n:=-n;
while n>0 do begin
Result+=1;
n:=n div 10
end
end;
function nDigits(s:string):=s.Length; // если строка
begin
Writeln(nDigits(1234567890123456)); // 16
Writeln(nDigits('123456789012345678901234567890')) // 30
end.
Результат
16
30
// Внимание! Если программа не работает, обновите версию!
function nDigits(n:int64):integer; // если число
begin
Result:=0;
if n<0 then n:=-n;
while n>0 do begin
Result+=1;
n:=n div 10
end
end;
function nDigits(s:string):=s.Length; // если строка
begin
Writeln(nDigits(1234567890123456)); // 16
Writeln(nDigits('123456789012345678901234567890')) // 30
end.
Результат
16
30
Новые вопросы
Алгебра,
2 года назад
Алгебра,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
История,
9 лет назад
Математика,
9 лет назад