Информатика, вопрос задал hiweke2926 , 2 года назад

Напишите программу , которая вычислит сумму числовой последовательности 1+8+16...8(n-1) и убедится , что она равна (2n-1)²

Ответы на вопрос

Ответил Аноним
0

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   int sum = 1, n;

   cin >> n;

   for(int i = 1; i < n; i++)

       sum += 8 * i;

   cout << "1 + 8 + 16 + ... + 8(n-1) = " << sum << "\n";

   cout << "(2n-1)^2 = " << pow(2*n-1,2);

}

Новые вопросы