Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами.
Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
1 4
Ответы на вопрос
Ответил danilbin
4
Program a;
var i,n,c: integer;
mas1,mas2 : array[1..10000] of integer;
begin c:=1;
write('размер массива = ');
read (n);
writeln('элементы массива: ');
for i:=1 to n do begin
read (n);
if (n>0) and (n<=10000) then begin
mas1[c]:=n;
inc(c);
end;
end;
n:=1;
writeln('Выходные данные: ');
i:=1;
while i<=(c-1) do begin
mas2[n]:=mas1[i];
inc(n);
i := i + 3;
end;
for i:=1 to n-1 do
write (mas2[i],' ');
end.
var i,n,c: integer;
mas1,mas2 : array[1..10000] of integer;
begin c:=1;
write('размер массива = ');
read (n);
writeln('элементы массива: ');
for i:=1 to n do begin
read (n);
if (n>0) and (n<=10000) then begin
mas1[c]:=n;
inc(c);
end;
end;
n:=1;
writeln('Выходные данные: ');
i:=1;
while i<=(c-1) do begin
mas2[n]:=mas1[i];
inc(n);
i := i + 3;
end;
for i:=1 to n-1 do
write (mas2[i],' ');
end.
Аноним:
огромное спасибо!!!!
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
2 года назад
Алгебра,
2 года назад
Геометрия,
7 лет назад