Информатика, вопрос задал sergemyatchin1 , 6 лет назад

Напишите программу, которая вводит строку, состоящую только из точек и букв Х, и заменяет в ней все точки на нули и все буквы X на единицы. ПАСКАЛЬ

Ответы на вопрос

Ответил Puz1koO
1

var

 s:string;

 i:integer;

begin

 write('Введите строку: '); readln(s);

 for i:=1 to length(s) do

   begin

     if s[i]= '.' then s[i]:= '0'

       else

         if (s[i]='X') or (s[i]='x') or

           (s[i]='х') or (s[i]='Х') then

             s[i]:='1';

   end;

 writeln('          Итог: ',s);

end.

Новые вопросы