напишите программу, которая вводит с клавиатуры 10 реальных чисел, и организовывает их хранение в массиве. После этого массив пересор- тировывается по закону: первый элемент меняется с последним
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//реальные числа - странное определение чисел вещественного типа
//Pascal ABC.NET v3.0 сборка 1111
Var
ar:array[1..10] of real;
i:integer;
k:real;
begin
writeln('Array:');
for i:=1 to 10 do
readln(ar[i]);
k:=ar[1];
ar[1]:=ar[10];
ar[10]:=k;
writeln('Final array:');
for i:=1 to 10 do
write(ar[i]:4);
end.
Пример ввода:
1
2
..
10
Пример вывода:
Final array:
10 2 3 4 5 6 7 8 9 1
//Pascal ABC.NET v3.0 сборка 1111
Var
ar:array[1..10] of real;
i:integer;
k:real;
begin
writeln('Array:');
for i:=1 to 10 do
readln(ar[i]);
k:=ar[1];
ar[1]:=ar[10];
ar[10]:=k;
writeln('Final array:');
for i:=1 to 10 do
write(ar[i]:4);
end.
Пример ввода:
1
2
..
10
Пример вывода:
Final array:
10 2 3 4 5 6 7 8 9 1
Новые вопросы
Биология,
2 года назад
География,
2 года назад
Математика,
9 лет назад
Алгебра,
9 лет назад
Биология,
9 лет назад