Информатика, вопрос задал avpavp95 , 9 лет назад

Напишите программу которая вводит координаты точки на плоскости и определяет? попала ли эта точка в заштрихованную область. (х*x+y*y=4; y=x; x=2)

Ответы на вопрос

Ответил Аноним
0
var
  x,y:real;
begin
  Write('Введите координаты x и y точки: '); Readln(x,y);
  Write('Точка с указанными координатами ');
  if not ((y<=x) and (x<=2) and ((sqr(x)+sqr(y))>=4) and (y>=0)) then
    Write('не ');
  Writeln('принадлежит заштрихованной области.')
end.

Примеры выполнения программы:
Введите координаты x и y точки: 1.9 2.1
Точка с указанными координатами не принадлежит заштрихованной области.

Введите координаты x и y точки: 1.9 1.82
Точка с указанными координатами принадлежит заштрихованной области.

Введите координаты x и y точки: 1 -3
Точка с указанными координатами не принадлежит заштрихованной области.


Ответил avpavp95
0
Спасибо!
Ответил Аноним
0
Пожалуйста
Новые вопросы