Информатика, вопрос задал 1agun0v , 9 лет назад

Напишите программу, которая вводит два числа A и N вычисляет A^N.
Програмный код. НЕ через "power". Заранее спасибо

Ответы на вопрос

Ответил APALoff
0
Function Pow(a : Integer; b : Integer) : Integer;
Begin
  If b=0 then Pow:=1 else Pow:=a*Pow(a,b-1);
End;

Var A,N : Integer;
Begin
  Readln(A,N);
  Writeln(Pow(A,N));
end.

Ответил 1agun0v
0
Претензии имеете ко мне?
Ответил APALoff
0
Я? Никаких. Свое решение я привёл в рамках Ваших первоначально заданных условиях - и мое решение, по моему мнению, полностью отвечает условиям.
Ответил 1agun0v
0
"Не вводя функции подобные этой, а получить расписав через "while", например,или "for" " Если распишите, чтобы понятно все было, то высказываю свою благодарность Вам и забираю свои упреки и недовольства обратно.
Ответил APALoff
0
Var R,A,N : Integer;
Begin
Readln(A,N);
R:=1;
While N>0 do
Begin
R:=R*A;
Dec(N);
end;
Writeln(R);
end.
Ответил 1agun0v
0
Спасибо^^.
Новые вопросы