Информатика, вопрос задал arinnaigorevna , 9 лет назад

Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения.


на си

Ответы на вопрос

Ответил iknowthatyoufeelbro
0
#include <cstdio>
long long ans, a;
int main()
{
  scanf("%lld", &a); //считываем исходное число
  a *= a; //возводим исходное число в квадрат
  ans = a; //в ответе хранится квадрат исходного числа
  a *= a; //в a хранится 4 степень исходного числа
  a *= a; //в a хранится 8 степень исходного числа
  ans *= a; //2 степень исходного числа умножаем на 8 степень
  printf("%lld", ans); //выводим ответ
  return 0;
}
Новые вопросы