Информатика, вопрос задал Alenhhy , 8 лет назад

Напишите программу, которая возводит натуральное число A в натуральную степень B .

Входные данные
Входная строка содержит два числа, A и B , разделённые пробелом. Гарантируется, что 1 ≤ A , B ≤ 1000 .

Выходные данные
Программа должна вывести одно число: A в степени B .

Примеры
входные данные
2 6
выходные данные
64.
Паскаль ABC 1.8

Ответы на вопрос

Ответил AnonimusPro
0
Program n1;
procedure st(n:longint; k: integer );
var i,m : longint;
begin
m:=n;
for i:=1 to k-1 do n:=n*m; writeln(n);
end;
var a,b: integer;
begin
readln(a,b);
if (a>=1) and (b<=1000) then st(a,b);
end.
Новые вопросы