напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)
Ответы на вопрос
Ответил BrightOne
0
// PascalABC.NET (версия 3.2, сборка 1363)
const
RM = 'ем';
var
c, n: char;
seq: boolean := False;
s: string := 'Земля - планета солнечной системы';
begin
writeln(s);
for var i := 1 to (length(s) -1) do
begin
c := s[i];
n := s[i+1];
if seq = True then
begin
seq := False;
continue;
end;
if (c = RM[1]) and (n = RM[2]) then
begin
seq := True;
continue;
end
else
begin
seq := False;
write(c);
end;
end;
write(s[length(s)]);
end.
const
RM = 'ем';
var
c, n: char;
seq: boolean := False;
s: string := 'Земля - планета солнечной системы';
begin
writeln(s);
for var i := 1 to (length(s) -1) do
begin
c := s[i];
n := s[i+1];
if seq = True then
begin
seq := False;
continue;
end;
if (c = RM[1]) and (n = RM[2]) then
begin
seq := True;
continue;
end
else
begin
seq := False;
write(c);
end;
end;
write(s[length(s)]);
end.
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('ем',''); s.Println
end.
Пример
> земля- планета солнечной системы
зля- планета солнечной систы
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('ем',''); s.Println
end.
Пример
> земля- планета солнечной системы
зля- планета солнечной систы
Новые вопросы
Алгебра,
2 года назад
Музыка,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад
Физика,
9 лет назад