Информатика, вопрос задал Csgorysskiimiasnik , 7 лет назад

Напишите программу, которая удаляет из введенной строки любой введенный с клавиатуры символ.
pascal.abc
даю 50 баллов срочно!!!!!

Ответы на вопрос

Ответил pinchuknastya9
0

Ответ:

Тут значительно легче без процедур решить. Вот, получайте!

program prim;

Var

s : string;

t : char;

k: integer;

begin

writeln ('Введите строку');

readln (s);

writeln ('Введите символ, который надо удалить');

readln (t);

while pos(t,s)<>0 do

begin

k:=pos(t,s);

Delete(s, k, 1);

end;

writeln ('Результат после удаления: ');

writeln(s);

end.

Новые вопросы