Напишите программу, которая строит случайную перестановку чисел от 1 до N – массив из N натуральных чисел, в котором есть все числа от 1 до N . При этом первым числом в перестановке обязательно должно быть число 5.
CPP
Входные данные
Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одну строку элементы полученного случайного массива, разделив их пробелами. В массиве должны присутствовать все натуральные числа от 1 до N , причём первым числом в перестановке обязательно должно быть число 5.
Примеры
входные данные
10
выходные данные
5 6 4 2 1 10 8 9 7 3
Ответы на вопрос
Ответил Helper211
0
Ответ:
#include <iostream>
#include <ctime>
int main()
{
int N, i, k, tmp;
int A[10000];
std::cin >> N;
for (i = 0; i < N; i++)
A[i] = i + 1;
srand(time(0));
tmp = A[0];
A[0] = A[4];
A[4] = tmp;
for (i = 1; i < N; i++)
{
tmp = A[i];
k = rand() % (N-1) + 1;
A[i] = A[k];
A[k] = tmp;
}
for (i = 0; i < N; i++)
std::cout << A[i] << " ";
return 0;
}
alibimukanov:
можете помочь с последней задачей
Новые вопросы