Информатика, вопрос задал Iriskathecat , 7 лет назад

Напишите программу которая сравнивает три числа и выводит произведение двух наименьших

Ответы на вопрос

Ответил AlexMytnyk
0
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int GetMin(vector<int> arr, int &index)
{
  int min = arr[0];
  index = 0;
  for (int i = 0; i < arr.size(); i++)
  {
    if (arr[i] < min)
    {
      index = i;
    }
  }
  return arr[index];
}
int main()
{
  vector<int> n;
  n.resize(3);
  cin >> n[0] >> n[1] >> n[2];
  int i = 0;
  int min1 = GetMin(n, i);
  n.erase(n.begin() + i);
  int min2 = GetMin(n, i);
  cout << min1 * min2;
  cin >> n[0];
  return 0;
}
Новые вопросы