Информатика, вопрос задал levalevin2013 , 9 лет назад

Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей. Ввод незнакомого имени должен провоцировать заявление типа «Я С ВАМИ НЕЗНАКОМА

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var names:array[1..2,1..5] of string:=
    (('Саша','Женя','Таня','Лена','Вася'),
    ('Александр','Евгений','Татьяна','Елена','Василий'));
  var name:=ReadlnString('Введите краткое имя:');
  var p:=0;
  for var i:=1 to 5 do
    if name=names[1,i] then begin p:=i; break end;
  if p>0 then Writeln(names[2,p])
  else Writeln('Я вас не знаю!')
end.

Тестовое решение
Введите краткое имя: Лена
Елена
Новые вопросы