Напишите программу,которая согласно запросу пользователя выводит информацию об абонентах с указанными фамилией и именем [На main.c]
Ответы на вопрос
#include <stdio.h>
#include <string.h>
#define MAX_ABONENTS 100
struct Abonent {
char surname[50];
char name[50];
char phone_number[20];
char address[100];
};
int main() {
struct Abonent abonents[MAX_ABONENTS];
int num_abonents = 0;
// Добавление абонентов в массив
// Запрос фамилии и имени у пользователя
char surname[50];
char name[50];
printf("Введите фамилию и имя абонента, которого хотите найти: ");
scanf("%s %s", surname, name);
// Поиск абонентов с указанной фамилией и именем
int found = 0;
for (int i = 0; i < num_abonents; i++) {
if (strcmp(abonents[i].surname, surname) == 0 && strcmp(abonents[i].name, name) == 0) {
printf("Фамилия: %s\n", abonents[i].surname);
printf("Имя: %s\n", abonents[i].name);
printf("Номер телефона: %s\n", abonents[i].phone_number);
printf("Адрес: %s\n", abonents[i].address);
found = 1;
}
}
if (!found) {
printf("Абонент с фамилией %s и именем %s не найден.\n", surname, name);
}
return 0;
}