Напишите программу, которая случайным образом выбирает дежурных: выводит два случайных числа на отрезке [1; N], где N – количество учеников вашего класса. Какая проблема может при этом возникнуть? c++
Ответы на вопрос
Ответил BobbyFresnel
1
===== С++ 17 =====
#include <iostream>
using namespace std;
int main()
{
int n;
cout << "Количество учеников: ";
cin >> n;
srand(time(NULL));
int m1 = rand() % n + 1, m2 = rand() % n + 1;
while(m2 == m1)
m2 = rand() % n + 1;
cout << m1 << " " << m2;
return 0;
}
Приложения:

Новые вопросы