Информатика, вопрос задал ipad17112000 , 2 года назад

Напишите программу, которая шифрует текст шифром Цезаря.

Приложения:

Ответы на вопрос

Ответил wherethefux
2

alphabet = "абвгдеёжзийклмнопрстуфхцчшщъыьэюя"

key = int(input("Введите ключ: "))

text = input("Введите текст: ")

result = ""

for letter in text:

   if letter in alphabet:

       letter_index = alphabet.find(letter)

       new_letter_index = (letter_index + key) % len(alphabet)

       result += alphabet[new_letter_index]

   else:

       result += letter

print(result)

Новые вопросы