Информатика, вопрос задал vahag2 , 2 года назад

Напишите программу, которая считывает названия трёх книг по одному в строке и выводит их в обратном порядке, тоже по одному в строке. На C++


vovapecherscky: Откуда она будет брать их название? Пользовательский или из файла?
vovapecherscky: название может состоять из нескольких слов? Названия будут в кавычках или просто разделённые пробелом?
vahag2: Пользовательский
vahag2: да может из нескольких слов. Разделены пробелом. И каждая строка должна завершаться переводом строки.
vahag2: программа должна быть написана типом string с использованием функции getline.
vovapecherscky: да, я понял

Ответы на вопрос

Ответил vovapecherscky
1

#include <iostream>

#include <string>

#include <windows.h>

using namespace std;

int main() {

setlocale(0, "RU");

SetConsoleOutputCP(1251);

SetConsoleCP(1251);

string *text = new string[3];

getline(cin, text[0]);

getline(cin, text[1]);

getline(cin, text[2]);

system("cls");

cout << text[2] << endl << text[1] << endl << text[0];

return 0;

}

Новые вопросы