Информатика, вопрос задал maximsmotraev , 7 лет назад

Напишите программу, которая считывает две введённые пользователем строки, проверяет, что обе они непустые, и выводит меньшую из них 5 раз подряд без пробелов.

В случае, если пустая строка была введена, выведите: Пусто!

Используйте *.

Формат ввода
Вводятся две разные строки.

Формат вывода
Вывести меньшую из строк 5 раз подряд без пробелов, если ни одна из строк не пустая.

В случае, если пустая строка была введена, выведите: Пусто!

Ответы на вопрос

Ответил vimmortal2
0

Ответ:

Вариант 1)

n1 = input()

n2 = input()

if len(n1) == 0 or len(n2) == 0:

   print('Пусто!')

else:

   if len(n1) > len(n2):

       print(f'{n1}\n{n1}\n{n1}\n{n1}\n{n1}')

   else:

       print(f'{n2}\n{n2}\n{n2}\n{n2}\n{n2}')

Вариант 2)

n1 = input()

n2 = input()

if n1 == '' or n2 == '':

   print('Пусто!')

else:

   for i in range(0,5):

       print(min(n1, n2))

Новые вопросы