Информатика, вопрос задал x4san0v , 2 года назад

Напишите программу, которая считывает 5 целых чисел, каждое на одной строке записывает их в массив и печатает этот массив наоборот на одной строке через пробелы. Использовать функции (readln, write, for downto). Пример

Ввод

1

2

3

4

5

Вывод

5 4 3 2 1

Ответы на вопрос

Ответил gfhjkmgfhjkm20
2

Ответ:

program z1;

var i: integer;

a:array [1..5] of integer;

begin

for i := 1 to 5 do readln (a[i]);

for i := 5 downto 1 do write (a[i],'  ')

end.

Объяснение:

Цикл со счётчиком:

for i := a to b do, где a <= b (от меньшего к большему)

for i := a downto b do, где a >= b (от большего к меньшему)

readln - ввод следующей строки с новой строки

write - вывод следующей строки с этой же строки

Новые вопросы