Информатика, вопрос задал baranovicaleksej107 , 2 года назад

Напишите программу,которая считает,Сколько целых чисел начиная с 0 нудно сложить чтобы их сумма не превышаоа число введенное с клавиатуры

Ответы на вопрос

Ответил maxum000
0

Python

n = int(input())

sum = 0

i = 0

while (sum<n):

   sum += i

   i += 1

print(i-1)

Вывод:

50                                                                                                                            

10

# (0+1+2+3+4+5+6+7+8+9=45| 45<50)

Новые вопросы