Информатика, вопрос задал naguy , 2 года назад

Напишите программу, которая считает произведение элементов массива целых чисел. Сначала задается целое число N = размер массива (он всегда меньше или равен 10), затем N целых чисел, каждая на отдельной строке. Вывести произведение. Ввод, вывод (readln, writeln).

Пример ввод

3

2

2

5

Вывод

20

Ответы на вопрос

Ответил fovfabomi
1

Предоставлю 2 программы

1)var a: array [1..10] of integer;

i,n,s: integer;

begin

read(n);

s:=1

for i:=1 to n do readln(a[i]);

for i:=1 to n do s:=s*a[i];

write(s);

end.

2)var a: array [1..10] of integer;

i,n,s: integer;

begin

read(n);

s:=1

for i:=1 to n do begin readln(a[i]); s:=s*a[i]; end;

write(s);

end.

Новые вопросы