Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.
Ответы на вопрос
Ответил petyaGavrikov
0
var a,b,i:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
for i:=a+1 to b-1 do
if i mod 2 = 0 then write(i,' ');
writeln;
end.
Пример:
a = 10
b = 20
12 14 16 18
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
for i:=a+1 to b-1 do
if i mod 2 = 0 then write(i,' ');
writeln;
end.
Пример:
a = 10
b = 20
12 14 16 18
Новые вопросы