Информатика, вопрос задал vlad66666v , 1 год назад

Напишите программу, которая работает с данными о студентах и их оценках. Пользователь будет вводить имя студента и его оценки. Программа должна сохранять эти данные в словаре, где имя студента будет ключом, а список его оценок - значением. Затем программа должна вычислить среднее значение оценок одного студента и вывести результат на экран.

Ответы на вопрос

Ответил andreyfedyanovich
0

python
students = {}

while True:

   name = input("Enter student name (or 'quit' to exit): ")

   if name == 'quit':

       break

   grades = []

   while True:

       grade = input("Enter grade (or 'done' to finish): ")

       if grade == 'done':

           break

       grades.append(int(grade))

   students[name] = grades

for name, grades in students.items():

   average = sum(grades) / len(grades)

   print(f"{name}: {grades} (average: {average:.2f})")

Прости но к сожелению я не могу на руский надеюсь помог:D

Новые вопросы