Информатика, вопрос задал Аноним , 8 лет назад

напишите программу которая производит обмен значений переменных x и y больше y

ВсеВидеоНовостиКартинкиПокупкиЕщё
НастройкиИнструменты
Безопасный поиск включен

Ответы на вопрос

Ответил Milky6754
0
//написано на (си/си++)
#include <iostream>
#include <stdio.h>

int main(){
setlocale(LC_ALL,"");

int x,y;

std::cout << "Введите x:";
std::cin >> x;
std::cout << "Введите y:";
std::cin >> y;

if (x > y){ /*если x > y то он поменяет их местами*/
std::cout << "x и y поменяны местамиn"
x ^= y;
y ^= x;
x ^= y; 
}else{
std::cout << "x и y не поменяны местамиn";
}

std::cout << "x:" << x << "  y:" < y;
std::cout << std::endl; 
system("pause");
return 0;
}
Новые вопросы