Информатика, вопрос задал skydyrmoldinova28 , 1 год назад

Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. Попробуйте ввести действительное число для числа знаков после запятой.


skydyrmoldinova: Можете привести 1 пример
fedrfedr: Не найду куда скриншот прикрепить. Личные сообщения отменили.
skydyrmoldinova: Я просто не понимаю
skydyrmoldinova: Нам не объяснили эту тему
fedrfedr: Добавьте новый вопрос - я вставлю программу с комментариями. А сюда ссылку, чтобы мне сообщение пришло. И объясните в каком виде нужен пример?
fedrfedr: Скриншот окна с выполненной программой ?
skydyrmoldinova: Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. Попробуйте ввести действительное число для числа знаков после запятой.
fedrfedr: Да нет, зачем мне нужно дублирование вопроса в комментариях? Я и так его вижу хорошо. Я просил через кнопку "добавить новый вопрос" сделать новую тему для добавления программы с объяснениями.

Ответы на вопрос

Ответил fedrfedr
3

Ответ:

program Real2;

var

 a, b, d: Real;

 id: Integer;

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b);

 Write ('Введите число знаков после запятой: ');

 Read (d);

 id := Trunc (d);

 WriteLn;

 Write ('Сумма = ', a + b :15 :id);

 ReadLn;

 ReadLn;

end.

Объяснение:

действительное число для количества знаков после запятой вводится в d, затем чтобы использовать его в форматировании вывода преобразуется в целое (id := Trunc (d); ).


fedrfedr: program Real2;

var

 a, b, d: Real; // объявление а и b будем суммировать, d - для определения с какой точностью выводить результат

 id: Integer; // сюда сохраним значение d, т.к. нужно целое число а не Real

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b); // ввод чисел в a и b

 Write ('Введите число знаков после запятой: ');

 Read (d); // ввод числа знаков после запятой, Ёклмн - вверху уже написано то же самое
fedrfedr:  id := Trunc (d); // d из real преобразуем в Integer, потому что эта фишка стоит в условиях задачи, можно было сразу вводить как целое число

 WriteLn;

 Write ('Сумма = ', a + b :15 :id); // вывод суммы a + b с точностью "id"

 ReadLn;

 ReadLn; // а это чтобы окно не сразу закрылось, программа ждет нажатия любой клавиши.

end. // всё конец! не понимаю зачем в школе учат программированию. сложить два числа - что еще проще может быть
fedrfedr: Написал в комментариях за два раза. больше 500 символов не даёт сайт вводить
Новые вопросы