Информатика, вопрос задал Bronzor1 , 7 лет назад

напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел

Ответы на вопрос

Ответил Аноним
0

javascript:var n = prompt("Введите n:"), массив = [], чётных = 0; for (let сч = 0; сч < n; сч++) массив.push(parseInt(prompt("["+сч+"]:"))); alert(массив + "n" + (массив.reduce(function (пр, тек) { if (тек % 2 == 0) { чётных++; return пр + тек; } else return пр; }, 0) / чётных));

Ответил Bronzor1
0
А почему я ввожу длину строки 5 и пишу числа: 1,2,3,4,5. Но он выводит среднее арифметическое четных чисел 12, хотя должно быть (2+4)/2=3?
Ответил Аноним
0
Проверяй. "parseInt" куда-то при вставке исчез.
Ответил Bronzor1
0
Да, работает, спасибо за ещё одно решение.
Ответил elenaklon
0

var a:array of integer;

n,i,s,k:integer;

begin

write('Введите количество элементов массива: ');

readln(n);

a:=new integer[n];

for i:=0 to n-1 do read(a[i]);

write ('Массив: ');

for i:=0 to n-1 do write(a[i],'  ');

writeln;

for i:=0 to n-1 do

if a[i]mod 2 = 0 then

begin

s:=s+a[i];

k:=k+1

end;

writeln('Среднее арифметическое чётных элементов массива равно: ',s/k:0:3)

end.

Ответил Bronzor1
0
Спасибо большое.
Новые вопросы