Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с помощью алгоритма Евклида. Программа должна подсчитать количество шагов цикла. С++
СРОЧНО
Ответы на вопрос
Ответил Омскаяптица
0
#include <iostream>
using namespace std;
int NOD(int a, int b) {
int iter = 0;
if (a < b) {
swap(a, b);
}
while (a % b != 0) {
a = a % b;
swap(a, b);
iter++;
}
cout<<"NOD: "<< b << " Iteration: "<< iter;
}
int main()
{
int a,b;
cin>>a>>b;
NOD(a,b);
return 0;
}
Приложения:

Новые вопросы
Французский язык,
2 года назад
Английский язык,
2 года назад
История,
2 года назад
Литература,
2 года назад
Математика,
8 лет назад