Напишите программу которая получает пять чисел и выводит количество одинаковых чисел в этой цепочке (Даю 80 баллов) Паскаль
Ответы на вопрос
Ответил Вованичикчка
0
var a: array [1..5] of integer;
i, j , count: integer;
repeated : boolean;
begin
for i := 1 to 5 do
begin
write('Введите ', i, '-e число: ');
readln(a[i]);
end;
for i := 1 to 5 do
begin
repeated := false;
for j := 1 to i - 1 do
if (a[i] = a[j]) then
repeated := true;
if repeated then continue;
count := 1;
for j:= i+1 to 5 do
if (a[i]=a[j]) then
inc(count);
writeln('Число ', a[i], ' встречается ', count,' раз');
end;
end.
MazeFac:
Спасибо брат
Новые вопросы