Информатика, вопрос задал Egor48889653 , 9 лет назад

Напишите программу, которая получает натуральные числа a и b(a меньше b) и выводит все простые числа в интервале от a до b

Ответы на вопрос

Ответил Giammy
0

PascalABC.NET 3.4.2, сборка 1933 от 01.04.2019

begin

 var (a, b) := ReadInteger2;  // Считывание a и b

 var simple := ArrFill(b + 1, true);  // Инициализация булевого массива значением true.

// Реализация решета Ератосфена

 for var i := 2 to b do

   if simple[i] then  

   begin

     var j := i * i;

     while (j <= b) do

     begin

       simple[j] := false;

       j += i;

     end;

   end;


 // Вывод на экран найденного результата

 for var i := a to b do

   if (simple[i]) and (i > 1) then i.Print

end.

Ответил 13nisa13
0

var a,b,i,d,k:integer;

begin

write ('Введите натуральные числа a и b (a<b): ');

readln (a,b);

write ('Простые числа от ',a,' до ',b,': ');

for i:=a to b do

begin

for d:=2 to i do

if i mod d = 0 then k:=k+1;

if k=1 then write(i,'  ');

k:=0

end

end.

Новые вопросы