Напишите программу, которая получает на вход строку типа "Иван Иванович Иванов"(ИОФ), а выводит строку типа "Иванов Иван Иванович"(ФИО)
Ответы на вопрос
Ответил czardurakov
0
Ответ:
как то так чтоль
var f,i,o,iof:string;
c,probel:integer;
begin
readln(iof);
probel:=0;
for c:=1 to length(iof) do begin
if (iof[c]<>' ') and (probel=0) then i:=i+iof[c];
if (iof[c]<>' ') and (probel=1) then o:=o+iof[c];
if (iof[c]<>' ') and (probel=2) then f:=f+iof[c];
if iof[c]=' ' then inc(probel);
end;
writeln(f,' ',i,' ',o);
end.
Объяснение:
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
История,
7 лет назад
Математика,
7 лет назад