Информатика, вопрос задал mmorozphone , 2 года назад

Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три цифры номер выход: первая строка представляет собой сумму цифр(в python)

Ответы на вопрос

Ответил Омскаяптица
2

Ответ:

n=int(input("Число: "))

sum = 0

while n>0:

   sum += n%10

   n=int(n/10)

   

print(sum)

Объяснение:

Приложения:
Ответил tothelove1
0

Ответ:

python не знаю, но подскажу.

Объяснение:

тебе нужно найти остаток от деления на 10, потом остаток прибавить к сумме. После, входное число нацело разделить на 10. Оставшейся число пропускаем через эти шаги до того момента, пока оно не будет равняться 0

Новые вопросы