Информатика, вопрос задал aloya2111 , 2 года назад

напишите программу которая подсчитывает количество цифр в натуральном числе N введённым с клавиатуры​

Ответы на вопрос

Ответил witchmay
0

#include <iostream>

using namespace std;

typedef long long ll;

int main()

{

  ll number, i = 0;

  cin >> number;

  while(number > 0){

      number/=10;

      ++i;

  }

  cout << i;

}

=========

// хитрый вариант с использованием строк на случай если число будет очень большое

=========

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string number;

  cin >> number;

  cout << number.size();

}


aloya2111: Спасибо большое. а можно написать, как в программе Паскаль
witchmay: program Problem;
var num, i: int64;
begin
i:= 0;
read(num);
while(num > 0) do begin
i := i + 1;
num := num div 10;
end;
write(i);
end.
Новые вопросы