напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.
Ответы на вопрос
Ответил Астрa
0
Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)
var a: integer;
begin
read(a);
if (a > 5) and (a <= 11) then
write('Утро ');
if (a > 11) and (a <= 17) then
write('День ');
if (a > 17) and (a <= 23) then
write('Вечер');
if (a = 24) or (a < 6) then
write('Ночь');
end.
var a: integer;
begin
read(a);
if (a > 5) and (a <= 11) then
write('Утро ');
if (a > 11) and (a <= 17) then
write('День ');
if (a > 17) and (a <= 23) then
write('Вечер');
if (a = 24) or (a < 6) then
write('Ночь');
end.
Ответил 123shevachka
0
if и case.
case из C++
case из C++
Ответил Астрa
0
по анкете ей 16, основная масса ответов в литературе, значит это её дз по школьному предмету, а в школе плюсы вроде не изучают( ну если не брать специализированную).
Ответил Астрa
0
case есть и в паскале, я загуглила)
Ответил 123shevachka
0
прикольно не знал что он и в паскале есть
Новые вопросы
Математика,
2 года назад
Геометрия,
2 года назад
Математика,
9 лет назад
Физика,
9 лет назад
Литература,
10 лет назад
История,
10 лет назад