Информатика, вопрос задал Zpok , 9 лет назад

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа

Пример ввода
12345

Пример вывода
55
С++ ПРОГРАММА

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Dev-C++ 5.11

#include <iostream>
#include <cmath>
using namespace std;

int main(void)
 {int n=0;
 float sum=0;
 cin>>n;
 for(int i=0;i<5;i++)
  {sum+=pow(n%10,2);
  n=n/10;}
 cout<<sum;
 return 0;}

Пример ввода:
11112
Пример вывода:
8
Новые вопросы