Информатика, вопрос задал skullsrock01 , 8 лет назад

Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество чётных натуральных чисел на отрезке [a, b] (включая концы отрезка).

Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 ≤ a ≤ b ≤ 30000. Проверять входные данные на корректность не нужно.

Программа должна вывести одно число: количество чётных чисел на отрезке [a, b].

Входные данные: 10 ;20
Выходные данные: 6

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2;
  var k:=(b-a) div 2;
  if a.IsEven or b.IsEven then k+=1;
  Writeln('На отрезке четных чисел ',k)
end.

Пример
143 1318
На отрезке четных чисел 588
Ответил skullsrock01
0
мне это нечего не дает
Ответил Аноним
0
А мне ничего не дает Ваш комментарий - я его не понимаю.
Новые вопросы