Информатика, вопрос задал ВерСоник , 9 лет назад

Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4×4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего флага. Внутри каждого флага должен быть записан его номер — число от 1 до n.
входные данные
1
выходные данные
+___
|1 /
|__
|

Паскаль. Нужно использовать фор.

Ответы на вопрос

Ответил NotOfNoumber
0
var 
 i,n:integer;
begin 
  read(n); 
  for i:=1 to n do   
   write('+___ '); 
  writeln; 
  for i:=1 to n do 
    write('|',i,' / '); 
  writeln; 
  for i:=1 to n do   
   write('|__ '); 
  writeln; 
 for i:=1 to n do 
    write('|    ');
end.
Новые вопросы