Напишите программу, которая "переворачивает" заданное натуральное число.
Очень нужно :с
Ответы на вопрос
Ответил pankovkostya99
0
Код в Паскале:
uses crt;
var n,k:integer;
begin clrscr;
write('Введите число: '); readln(n);
repeat
k:=k*10+(n mod 10);
n:=n div 10;
until(n=0);
writeln('Обратный порядок: ', k);
readln;
end.
Копировать тут(без скобок):
{ uses crt;var n,k:integer;beginclrscr;write('Введите число: '); readln(n);repeatk:=k*10+(n mod 10);n:=n div 10;until(n=0);writeln('Обратный порядок: ', k);readln;end. }
uses crt;
var n,k:integer;
begin clrscr;
write('Введите число: '); readln(n);
repeat
k:=k*10+(n mod 10);
n:=n div 10;
until(n=0);
writeln('Обратный порядок: ', k);
readln;
end.
Копировать тут(без скобок):
{ uses crt;var n,k:integer;beginclrscr;write('Введите число: '); readln(n);repeatk:=k*10+(n mod 10);n:=n div 10;until(n=0);writeln('Обратный порядок: ', k);readln;end. }
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Геометрия,
10 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад