Напишите программу которая отобразит числа в порядке пирамиды Паскаля. Программа должна вычислить и отобразить 15 этажей пирамиды С++
Ответы на вопрос
Ответил igorShap
0
#include <iostream>
#include <iomanip>
using namespace std;
#define N 15
#define S 128
int main () {
int mas[S];
for(int n = 0; n < N; n++) {
mas[0] = 1;
for(int i = 1; i <= n ; i++)
mas[i] = 0;
for(int i = 1; i <= n; i++)
for(int j = i; j >= 1; j--)
mas[j] += mas[j-1];
cout << setw(2) << n << ":";
for(int i = 0; i < 35 - 5 * n / 2; i++)
cout << " ";
for(int i = 0; i <= n ; i++)
cout << setw(5) << mas[i];
cout << endl;
}
return 0;
}
Приложения:

Ответил igorShap
0
К сожалению, форматирование редактор не сохраняет, поэтому прикрепил .cpp файл и скриншот результата
Ответил TequilaSunrise
0
помогите, пожалуйста, если не затруднит (: https://znanija.com/task/30345640
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад